Join Amazon Student FREE Two-Day Shipping for College Students!

Disable ASUS Motherboard's UEFI secure boot

Disable ASUS Motherboard's UEFI secure boot

Most new ASUS motherboards do not have the option to let users to turn off the UEFI secure boot. The "Secure Boot Enabled" is always greyed out and unable to change that option. Yet, we do have the option to disable the secure boot by clearing secure boot keys. This is reversible so no need to worry about breaking the warranty or damaging the BIOS.

BIOS's Secure Boot menu should show Secure Boot state as "enabled" and Platform Key (PK) state as "loaded"


How to disable the UEFI secure boot:

  1. Make sure the "OS Type" is "Windows UEFI"
  2. Enter "Key Management"
  3. Select "Clear Secure Boot keys" (You will have the option "Install default Secure Boot keys" to restore the default keys after you cleared the Secure Boot Keys)


After you cleared the Secure Boot Keys, Secure Boot will be automatically disabled. You can set the OS Type to Other OS now.



  1. Max says:

    Hey there, I'm trying to install Ubuntu 16.04.1 on an ASUS A88X-PLUS. You were my last hope, but even after disabling secure boot my screen just goes black after I select "Install Ubuntu" from the USB drive. I used an ISO and Rufus to create the drive, worked fine for Windows, but somehow Ubuntu doesn't seem right.
    My screen goes black, as described, the drive keeps blinking for a while and then everything stops. The PC is running, but nothing happens. I also forced the internal GPU, in case that was in the way. There also isn't the usual graphic interface for installing Ubuntu I know from old computers we've had it running on, just a frame with 4 lines of text, so I believe it must be a booting problem.

    I just can't seem to find the correct search terms for the problem, maybe you can help, Sorry ๐Ÿ™

  2. Amckinney says:

    Hi all,
    I tried the other OS boot option and PK keys unload d and I am now getting 0xc000000f error if I reset defaults I get the secure boot error...please help have school paper due!

  3. jackobyte says:

    i'm sure that knave Gates is paying manufacturers to not make secure boot easily disabled. In fact all he has to do is pay off AMI and hes done, the creeping snake. I just bought an asus x99-a and support told me tough you cant turn secure boot off WTF... what are they getting out of that? they ain't saints either i'm sure

  4. vasanth says:

    Hello am trying to install windows 7 in asus h110m motherboard iys not taking the os... pl help me

    • Evan says:

      Are you trying to install Windows 7 in UEFI? For W7 you will need to enable CSM and boot your computer then press F8 to launch the select boot device screen, select your installation drive with UEFI mark.

  5. Johnny Bravo says:

    I have a ASUS G11 and for the live of me cant install linux. I've disable the secuirty boot in the past but no luck. The only OS I can get to run is shitty WIN10. Anything else wont work..if someone have the same computer and have anything else other that WIN10,please advise me in how to to do so..Thank you for your time.

  6. Wendy says:

    Have you successfully installed a Linux OS after this. I have not tried this, and can't get a Linux OS to install.

    • EX says:

      I have installed Mac OS - Yosemite ๐Ÿ™‚

      • Wendy says:

        I have an ASUS M32CD with the 602 UEFI version. This is the ONLY place I've found instructions for turning off secure boot on ASUS for newer ASUS UEFI.

        I keep getting an error when trying to boot a live DVD, even when it is set to Other OS, and I'm wondering if secure boot, my skylake chipset Nvidia graphics card or something else is the issue.

        • EX says:

          The error that you get maybe because your turned off the legacy BIOS compatibility mode. You need to turn it on and chose UEFI boot from there for some live CD. Same for Windows 7 UEFI boot.

  7. Stephen says:

    Asus hero VIII - cannot see an option to "clear secure bot keys"

    • EX says:

      It may have something similar to that. I don't have VIII board so I can't tell the difference.

      • Irene Schwarz says:

        they appearing again after reboot (asus Gene VIII), damn uefi, that bloody microsft forcing to use only windows by that? shite, and burn in hell this jew william gates

        • Stephen says:

          Somehow I didn't expect to hear racism spouted on a tech forum. But it certainly drives home how wrong that kind of remark is.

Leave a Reply

Your email address will not be published. Required fields are marked *


Your browser is out-of-date. Upgrade your browser today! Internet Explorer | FireFox | Chrome